Использование в системе умный дом

AC1900 Высокопроизводительный двухдиапазонный беспроводной гигабитный маршрутизатор
Ответить
a_s_morozov@bk.ru
Сообщения: 4
Зарегистрирован: 07 май 2019, 11:26
Страна: Россия

Использование в системе умный дом

Сообщение a_s_morozov@bk.ru » 07 май 2019, 11:33

Название темы: Использование в системе умный дом
Аппаратная версия устройства: ver 1.1
Тип подключения: Static IP
Описание проблемы: При запуске приложения на устройстве с MQTT протоколом на порт 1883, через WIFI, устройство перестаёт пинговаться с локального ПК. С роутера пинги проходят. В чём может быть проблема?
Уровень сигнала от основного роутера: 4-5 делений

Boris
Сообщения: 403
Зарегистрирован: 05 май 2012, 11:40
Страна: Россия
Откуда: Москва

Re: Использование в системе умный дом

Сообщение Boris » 07 май 2019, 11:51

Поясните подробнее. Кто что пингует, с какими ip-адресами. Какая схема подключения. В чём конкретно проблема.
Мои модели:
TL-ER604W
TL-MR3420
TL-WDR3600

Помогу с настройкой TP-LINK. Пишите в ЛС.

a_s_morozov@bk.ru
Сообщения: 4
Зарегистрирован: 07 май 2019, 11:26
Страна: Россия

Re: Использование в системе умный дом

Сообщение a_s_morozov@bk.ru » 07 май 2019, 12:22

К роутеру подключены по WIFI датчики по MQTT протоколу, через порт 1883, датчики я настраиваю с локального ПК, который подключен к роутеру через лан кабель. К датчикам я подключаюсь через WIFI, программу и 23 порт. Коннект к датчикам есть до тех пор пока я на них не запускаю работу по MQTT протоколу через порт 1883. MQTT server находиться в тойже локальной сети. В общем проблема состоит в том что пропадает связь локального ПК и датчиков, перестают пинговаться. Помогает отключение MQTT на датчиках и перезагрузка роутера.
IP ПК 192.168.0.116 lan
IP датчика 192.168.0.121 wifi
IP роутера 192.168.0.1 lan
IP сервера mqtt 192.168.0.181 lan

a_s_morozov@bk.ru
Сообщения: 4
Зарегистрирован: 07 май 2019, 11:26
Страна: Россия

Re: Использование в системе умный дом

Сообщение a_s_morozov@bk.ru » 07 май 2019, 12:32

Версия ПО 1.1.0 Build 20180910 rel.40619(5255)

Boris
Сообщения: 403
Зарегистрирован: 05 май 2012, 11:40
Страна: Россия
Откуда: Москва

Re: Использование в системе умный дом

Сообщение Boris » 07 май 2019, 13:17

Хорошо, а при чём тут роутер? В чём он виноват? Что говорит производитель датчиков? Я бы на сервере 192.168.0.181 настроил снифер сетевого трафика и выяснил причину проблемы.
Ваш сервер в момент проблемы видит датчики? Или с ними связь тоже теряется? Может просто ваши датчики из-за чего то уходят в ступор и тупо виснут? Я бы копал в этом направлении.
Мои модели:
TL-ER604W
TL-MR3420
TL-WDR3600

Помогу с настройкой TP-LINK. Пишите в ЛС.

a_s_morozov@bk.ru
Сообщения: 4
Зарегистрирован: 07 май 2019, 11:26
Страна: Россия

Re: Использование в системе умный дом

Сообщение a_s_morozov@bk.ru » 07 май 2019, 14:49

Да, все всех видят кроме ПК. Проблема решена. Всему виной, клонированный в роутер, мак адрес локального ПК.
Роутер тут во всём виноват так как эта конфигурация работает в других сетях без проблем :)
Конфликт мак адресов всему виной

Goodwin
Модератор
Модератор
Сообщения: 3882
Зарегистрирован: 25 май 2011, 10:56
Страна: Россия

Re: Использование в системе умный дом

Сообщение Goodwin » 08 май 2019, 12:05

WAN и LAN интерфейсы конфликтовать не могут.
Перед тем, как создать тему, посетите раздел ЧАСТО ЗАДАВАЕМЫЕ ВОПРОСЫ
TP-LINK Archer C7v2
Личные сообщения по техническим проблемам без сообщения на форуме не рассматриваются!

Ответить

Вернуться в «Archer C9»