Страница 1 из 1

Проблема с IPV6 на LAN (6in4-henet)

Добавлено: 07 ноя 2018, 15:01
Hero2006
Добрый день,
имеется устройство "TP-Link TL-WR841N/ND v8" с прошивкой "LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)".
Ipv6 подключен успешно через HENET брокера, во внутренней сети (LAN) есть два основных устройства PC и NAS.
На компьютере dualboot. Если компьютер работает под Win 7 никаких проблем нет, т.е. ipv6 dns адреса резолвятся, коннект и пинг все ок.

Код: Выделить всё

ipconfig

Код: Выделить всё

Настройка протокола IP для Windows


Ethernet adapter Подключение по локальной сети:

   DNS-суффикс подключения . . . . . : lan
   IPv6-адрес. . . . . . . . . . . . : 2001:470:7870::121
   IPv6-адрес. . . . . . . . . . . . : 2001:470:7870:0:98b5:3790:1314:527a
   IPv6-адрес. . . . . . . . . . . . : fde2:f422:369::121
   IPv6-адрес. . . . . . . . . . . . : fde2:f422:369:0:98b5:3790:1314:527a
   Временный IPv6-адрес. . . . . . . : 2001:470:7870:0:b166:9843:3972:195a
   Временный IPv6-адрес. . . . . . . : fde2:f422:369:0:b166:9843:3972:195a
   Локальный IPv6-адрес канала . . . : fe80::98b5:3790:1314:527a%12
   IPv4-адрес. . . . . . . . . . . . : 192.168.1.121
   Маска подсети . . . . . . . . . . : 255.255.255.0
   Основной шлюз. . . . . . . . . : fe80::92f6:52ff:fef8:186e%12
                                       192.168.1.1

Ethernet adapter VirtualBox Host-Only Network:

   DNS-суффикс подключения . . . . . : 
   Локальный IPv6-адрес канала . . . : fe80::99ad:be3b:90ad:3b87%13
   IPv4-адрес. . . . . . . . . . . . : 192.168.56.1
   Маска подсети . . . . . . . . . . : 255.255.255.0
   Основной шлюз. . . . . . . . . : 

Туннельный адаптер isatap.lan:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . : lan

Туннельный адаптер isatap.{1193FAAA-33D8-41AF-B706-E3E95782A44A}:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . : 

Код: Выделить всё

===========================================================================
Список интерфейсов
 12...14 da e9 f4 9f 24 ......Realtek PCIe GbE Family Controller
 13...0a 00 27 00 00 0d ......VirtualBox Host-Only Ethernet Adapter
  1...........................Software Loopback Interface 1
 11...00 00 00 00 00 00 00 e0 Адаптер Microsoft ISATAP
 14...00 00 00 00 00 00 00 e0 Адаптер Microsoft ISATAP #2
===========================================================================

IPv4 таблица маршрута
===========================================================================
Активные маршруты:
Сетевой адрес           Маска сети      Адрес шлюза       Интерфейс  Метрика
          0.0.0.0          0.0.0.0      192.168.1.1    192.168.1.121     10
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      192.168.1.0    255.255.255.0         On-link     192.168.1.121    266
    192.168.1.121  255.255.255.255         On-link     192.168.1.121    266
    192.168.1.255  255.255.255.255         On-link     192.168.1.121    266
     192.168.56.0    255.255.255.0         On-link      192.168.56.1    266
     192.168.56.1  255.255.255.255         On-link      192.168.56.1    266
   192.168.56.255  255.255.255.255         On-link      192.168.56.1    266
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link     192.168.1.121    266
        224.0.0.0        240.0.0.0         On-link      192.168.56.1    266
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link     192.168.1.121    266
  255.255.255.255  255.255.255.255         On-link      192.168.56.1    266
===========================================================================
Постоянные маршруты:
  Отсутствует

IPv6 таблица маршрута
===========================================================================
Активные маршруты:
 Метрика   Сетевой адрес            Шлюз
 12    266 ::/0                     fe80::92f6:52ff:fef8:186e
  1    306 ::1/128                  On-link
 12    266 2001:470:7870::/48       fe80::92f6:52ff:fef8:186e
 12     18 2001:470:7870::/64       On-link
 12    266 2001:470:7870::121/128   On-link
 12    266 2001:470:7870:0:98b5:3790:1314:527a/128
                                    On-link
 12    266 2001:470:7870:0:b166:9843:3972:195a/128
                                    On-link
 12    266 fde2:f422:369::/48       fe80::92f6:52ff:fef8:186e
 12     18 fde2:f422:369::/64       On-link
 12    266 fde2:f422:369::121/128   On-link
 12    266 fde2:f422:369:0:98b5:3790:1314:527a/128
                                    On-link
 12    266 fde2:f422:369:0:b166:9843:3972:195a/128
                                    On-link
 12    266 fe80::/64                On-link
 13    266 fe80::/64                On-link
 12    266 fe80::98b5:3790:1314:527a/128
                                    On-link
 13    266 fe80::99ad:be3b:90ad:3b87/128
                                    On-link
  1    306 ff00::/8                 On-link
 12    266 ff00::/8                 On-link
 13    266 ff00::/8                 On-link
===========================================================================
Постоянные маршруты:
  Отсутствует
Проблема появляется при загрузке под линуксом (ArchLinux последний) и на NAS (Synology=Linux). Заключается в том, ipv6 dns имена резолвятся, но ни пинг (таймаут), ни коннект (таймаут) - не работают. От слова совсем. Проблема одинаково проявляется также на nas. Сеть на компьютере настроена через netctl

Код: Выделить всё

cat /etc/netctl/my_dhcp

Код: Выделить всё

Description='A basic dhcp ethernet connection'
Interface=enp5s0
Connection=ethernet
IP=dhcp
#DHCPClient=dhcpcd
#DHCPReleaseOnStop=no
## for DHCPv6
#IP6=dhcp
#DHCP6Client=dhclient
## for IPv6 autoconfiguration
#IP6=stateless // Пробовал раскомментировать = не помогло

ExecUpPost='/usr/bin/ip link set enp5s0 mtu 9000'

Код: Выделить всё

ping -c 3 google.com                                                                                                                                                                                                                             ~
PING google.com(ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e)) 56 data bytes

--- google.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 32ms

telnet google.com 80                                                                                                                                                                                                                             ~
Trying 2607:f8b0:4009:805::200e...

asd
sdf
sdf
sdf
Connection failed: Время ожидания соединения истекло
Trying 172.217.4.206...
Connected to google.com.
Escape character is '^]'.
HTTP/1.0 400 Bad Request
Content-Type: text/html; charset=UTF-8
...

Код: Выделить всё

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc fq_codel state UP group default qlen 1000
    link/ether 14:da:e9:f4:9f:24 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.121/24 brd 192.168.1.255 scope global noprefixroute enp5s0
       valid_lft forever preferred_lft forever
    inet6 fde2:f422:369:0:16da:e9ff:fef4:9f24/64 scope global dynamic mngtmpaddr 
       valid_lft forever preferred_lft forever
    inet6 2001:470:7870:0:16da:e9ff:fef4:9f24/64 scope global dynamic mngtmpaddr 
       valid_lft forever preferred_lft forever
    inet6 fe80::16da:e9ff:fef4:9f24/64 scope link 
       valid_lft forever preferred_lft forever
Конфигурация роутера:

Код: Выделить всё

cat /etc/config/network

Код: Выделить всё

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:f422:0369::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option igmp_snooping '1'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'pppoe-login'
        option password 'pppoe-pass'
        option ipv6 'auto'
        option peerdns '0'
        option dns '139.99.96.146 92.222.97.145'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'henet'
        option proto '6in4'
        option peeraddr '216.66.84.46'
        option ip6addr '2001:470:1f14:cb::2/64'
        option tunnelid 'my_id'
        option username 'my_username'
        option password 'my_password'
        option ip6prefix '2001:470:7870::/48'

Код: Выделить всё

cat /etc/config/dhcp

Код: Выделить всё

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option nonwildcard '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config host
        option name 'pc'
        option dns '1'
        option mac '14:da:e9:f4:9f:24'
        option ip '192.168.1.121'

config host
        option name 'DiskStation'
        option dns '1'
        option mac '00:11:32:1b:79:82'
        option ip '192.168.1.124'

Код: Выделить всё

cat /etc/config/firewall

Код: Выделить всё

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan henet'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'
Немного магии-логика обывальщика. Пока пытался разобраться с этой проблемой использовал статьи:
https://openwrt.org/docs/guide-user/net ... interfaces
А также общая https://wiki.archlinux.org/index.php/IPv6

Код: Выделить всё

ping ff02::1%enp5s0

Код: Выделить всё

PING ff02::1%enp5s0(ff02::1%enp5s0) 56 data bytes
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=1 ttl=64 time=0.038 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=1 ttl=64 time=0.238 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=1 ttl=64 time=0.466 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=1 ttl=1 time=1.74 ms (DUP!)
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=2 ttl=64 time=0.046 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=2 ttl=64 time=0.202 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=2 ttl=64 time=0.502 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=2 ttl=1 time=1.69 ms (DUP!)
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=3 ttl=64 time=0.048 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=3 ttl=64 time=0.192 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=3 ttl=64 time=0.521 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=3 ttl=1 time=2.24 ms (DUP!)
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=4 ttl=64 time=0.025 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=4 ttl=64 time=0.208 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=4 ttl=64 time=0.490 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=4 ttl=1 time=2.17 ms (DUP!)
^C
--- ff02::1%enp5s0 ping statistics ---
4 packets transmitted, 4 received, +12 duplicates, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 0.025/0.676/2.238/0.769 ms
Решил пингануть свой текущий ipv6 адрес на HENET интерфейсе. (таймаут)

Код: Выделить всё

ping 2001:470:1f14:cb::2

Код: Выделить всё

^CPING 2001:470:1f14:cb::2(2001:470:1f14:cb::2) 56 data bytes

--- 2001:470:1f14:cb::2 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 11ms
Пингую ipv6 роутера (Успешно!)

Код: Выделить всё

ping 2001:470:7870::1

Код: Выделить всё

PING 2001:470:7870::1(2001:470:7870::1) 56 data bytes
64 bytes from 2001:470:7870::1: icmp_seq=1 ttl=64 time=0.840 ms
64 bytes from 2001:470:7870::1: icmp_seq=2 ttl=64 time=0.321 ms
64 bytes from 2001:470:7870::1: icmp_seq=3 ttl=64 time=0.328 ms
^C
--- 2001:470:7870::1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 25ms
rtt min/avg/max/mdev = 0.321/0.496/0.840/0.243 ms
Сразу после этого ipv6 работает, т.е.

Код: Выделить всё

ping 2001:470:1f14:cb::2

Код: Выделить всё

PING 2001:470:1f14:cb::2(2001:470:1f14:cb::2) 56 data bytes
64 bytes from 2001:470:1f14:cb::2: icmp_seq=1 ttl=64 time=0.297 ms
64 bytes from 2001:470:1f14:cb::2: icmp_seq=2 ttl=64 time=0.330 ms
64 bytes from 2001:470:1f14:cb::2: icmp_seq=3 ttl=64 time=0.283 ms
^C
--- 2001:470:1f14:cb::2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 37ms
rtt min/avg/max/mdev = 0.283/0.303/0.330/0.024 ms

Код: Выделить всё

ping google.com

Код: Выделить всё

PING google.com(ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e)) 56 data bytes
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=1 ttl=52 time=264 ms
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=2 ttl=52 time=264 ms
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=3 ttl=52 time=264 ms
^C
--- google.com ping statistics ---
4 packets transmitted, 3 received, 25% packet loss, time 7ms
rtt min/avg/max/mdev = 263.737/263.793/263.837/0.594 ms
Абсолютно такое же поведение на NAS, т.е. после того, как вручную сделать пинг роутера Ipv6 начинает корректно работать.
Решение временное, через какое-то время перестает работать, после перезагрузки тоже. (также и на NAS)
Подробнее спустя некоторое время перестает работать, тем же методом - пингануть роутер - работа уже не восстанавливается, помогает перезапуск интерфейса (netctl restart my_dhcp)

Друзья, очень надеюсь на хороший совет, я мало разбираюсь в данной теме.

Re: Проблема с IPV6 на LAN (6in4-henet)

Добавлено: 08 ноя 2018, 11:29
Hero2006
Тему можно закрывать, в моем случае нужно было убрать ULA prefix.
Решение получил здесь.
https://forum.openwrt.org/t/ipv6-on-lan ... et/24769/4