Wake-on-lan на TL-WR1043ND

Беспроводные гигабитные маршрутизаторы серии N
Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Wake-on-lan на TL-WR1043ND

Сообщение Comp » 21 окт 2011, 14:33

Здравствуйте, можно ли как нибудь прикрутить wake on lan на данном маршрутизаторе? Если да, то как его настроить? В общем цель какая, через какой нибудь сервис (например через http://www.dslreports.com/wakeup) будить компьютер через интернет. dyndns настроен, 9 порт открыт, в свойствах сетевухи галочка поставлена.... но он нивкакую!Где-то читал, что в настройки nat нужно прописывать широковещательный адрес типа 192.168.1.255. Но роутер не хочет его принимать..... Может кто подскажет, что можно сделать?

GPS

Re: Wake-on-lan на TL-WR1043ND

Сообщение GPS » 21 окт 2011, 14:57

Comp писал(а):Здравствуйте, можно ли как нибудь прикрутить wake on lan на данном маршрутизаторе? Если да, то как его настроить? В общем цель какая, через какой нибудь сервис (например через http://www.dslreports.com/wakeup) будить компьютер через интернет. dyndns настроен, 9 порт открыт, в свойствах сетевухи галочка поставлена.... но он нивкакую!Где-то читал, что в настройки nat нужно прописывать широковещательный адрес типа 192.168.1.255. Но роутер не хочет его принимать..... Может кто подскажет, что можно сделать?

Проверьте для начала напрямую без роутера компьютер "просыпается" ?

Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение Comp » 21 окт 2011, 14:58

В том-то и дело, что на прямую работает..... :(

GPS

Re: Wake-on-lan на TL-WR1043ND

Сообщение GPS » 21 окт 2011, 15:01

Тогда выложите здесь ксрин проброса порта (virtual server), а также вопрос - какой IP и МАС вы прописываете, как я понимаю, на этом сайте.

Попробуйте еще отключить firewaal в настройках Security роутера, а также попробуйте добавить ваш компьютер в DMZ (в разделе forwarding).

Помогло ли что-нибудь из этого ?

Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение Comp » 22 окт 2011, 00:11

Вопрос в другом..... Сразу после выключения компьютера (1-3 мин) через сервис он включается т.е. на роутере по идее настроено все правильно, но позже никак.... :(

GPS

Re: Wake-on-lan на TL-WR1043ND

Сообщение GPS » 24 окт 2011, 11:57

Comp писал(а):Вопрос в другом..... Сразу после выключения компьютера (1-3 мин) через сервис он включается т.е. на роутере по идее настроено все правильно, но позже никак.... :(

Т.е. после отключения компьютера и после 3 минут уже не включается, а в период до 3 минут нормально ?

Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение Comp » 24 окт 2011, 13:14

Ага, я так понимаю мак теряется из таблицы маршрутизации.

masterlan
Сообщения: 43
Зарегистрирован: 20 сен 2011, 16:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение masterlan » 30 окт 2011, 20:57

Скажите Comp, по какой инструкции вы настраивали роутер для WOL-а ?
Я пол дня бадаюсь вот по этой http://forum.tp-link.su/viewtopic.php?f ... start=1900и пока ничего не выходит. Поделитесь инфой, плиз. :)

Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение Comp » 01 ноя 2011, 11:24

masterlan писал(а):Скажите Comp, по какой инструкции вы настраивали роутер для WOL-а ?
Я пол дня бадаюсь вот по этой http://forum.tp-link.su/viewtopic.php?f ... start=1900и пока ничего не выходит. Поделитесь инфой, плиз. :)
По этой инструкции и настраивал, только от этой инструкции толку ноль (если вы, конечно, не хотите включить компьютер через 1-2 минуты после выключения) т.к. через 3 мин мак адрес вашей сетевой маршрутизатор забывает, и не знает на какой порт отправлять WOL пакет. Вот если бы наша железка понимала широковещательные адреса (типа 192.168.1.255). Тогда было бы все ОК! Так что ждем новых прошивок и надеемся...... ;)

masterlan
Сообщения: 43
Зарегистрирован: 20 сен 2011, 16:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение masterlan » 02 ноя 2011, 00:52

Вы не поверите ! :)
Я его таки добадал. И несколько раз уже проверил. Есть вейк-ап подъём. Есть!
И по той самой инструкции. Всё сработало, только я изначально забыл поставить один пакет и выполнить одну команду. А как только вспомнил и сделал , то всё заработало.
Kubuntu 11.10
+ пакет ethtool
+ команда ethtool -s eth0 wol g; echo enabled > /sys/class/net/eth0/device/power/wakeup

Ответить

Вернуться в «TL-WR1043ND / TL-WR1045ND»