Wake-on-lan на TL-WR1043ND

Беспроводные гигабитные маршрутизаторы серии N
Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Wake-on-lan на TL-WR1043ND

Сообщение Comp » 21 окт 2011, 14:33

Здравствуйте, можно ли как нибудь прикрутить wake on lan на данном маршрутизаторе? Если да, то как его настроить? В общем цель какая, через какой нибудь сервис (например через http://www.dslreports.com/wakeup) будить компьютер через интернет. dyndns настроен, 9 порт открыт, в свойствах сетевухи галочка поставлена.... но он нивкакую!Где-то читал, что в настройки nat нужно прописывать широковещательный адрес типа 192.168.1.255. Но роутер не хочет его принимать..... Может кто подскажет, что можно сделать?

Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение Comp » 07 ноя 2011, 11:34

masterlan писал(а):Вы не поверите ! :)
Я его таки добадал. И несколько раз уже проверил. Есть вейк-ап подъём. Есть!
И по той самой инструкции. Всё сработало, только я изначально забыл поставить один пакет и выполнить одну команду. А как только вспомнил и сделал , то всё заработало.
Kubuntu 11.10
+ пакет ethtool
+ команда ethtool -s eth0 wol g; echo enabled > /sys/class/net/eth0/device/power/wakeup
А комп просыпается через, допустим, пол часа?

masterlan
Сообщения: 43
Зарегистрирован: 20 сен 2011, 16:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение masterlan » 07 ноя 2011, 11:53

Нет, не "через, допустим, пол часа", а сразу по получению магического пакета, т.е. примерно через секунду-две.

Comp
Сообщения: 10
Зарегистрирован: 21 окт 2011, 14:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение Comp » 12 ноя 2011, 17:23

Нет, вы меня не так поняли..... Компьютер включается, если отослать пакет через пол часа, после выключения????

masterlan
Сообщения: 43
Зарегистрирован: 20 сен 2011, 16:22

Re: Wake-on-lan на TL-WR1043ND

Сообщение masterlan » 13 ноя 2011, 01:48

Сорри, действительно не так понял.
Да ,компьютер включается, если отослать пакет через пол часа, после выключения.
Пробовал конечно не точь в точь "через пол часа".
Пробовал часов через 10 после выключения компа - всё ок.
Повторно пробовал более чем через сутки и тоже всё ок.
Пакет отсылал через службу http://www.dslreports.com/wakeup.
При настройке компа использовал анализатор трафика Wireshark.
Ну и комп мой с дуальной системой, основная - Kubuntu 11.10 , вторая (детям на поиграть) - WinXpSP3.
Комп поднимается будучи выключенным из обеих систем. В винде для этого настраивал свойства сетевой карты, а про кубунту уже писал выше.

Parial
Сообщения: 8
Зарегистрирован: 29 окт 2011, 12:46

Re: Wake-on-lan на TL-WR1043ND

Сообщение Parial » 27 окт 2012, 13:24

АПаю тему, ибо такая же проблема как у автора (только у меня комп включается через WOL в течении 30 секунд после выключения компа, маршрутизатор WR841ND, кто нибудь нашел решение?

Simulacra
Сообщения: 9
Зарегистрирован: 10 апр 2012, 23:37

Re: Wake-on-lan на TL-WR1043ND

Сообщение Simulacra » 04 фев 2013, 16:27

Было бы правильным эту опцию встроить в веб-интерфейс роутера.

Подскажите, может на альтернативных прошивках так и сделано?

KxD
Сообщения: 2
Зарегистрирован: 23 май 2014, 22:09
Страна: Украина

Re: Wake-on-lan на TL-WR1043ND

Сообщение KxD » 23 май 2014, 22:32

даа, много воды утекло с начала этой темы, а вопросы все таки остались.
У меня та же история. Комп включается, но только какое-то не большое время после выключения.
А пост от masterlan я так и не понял.
"Вы не поверите ! :)
Я его таки добадал. И несколько раз уже проверил. Есть вейк-ап подъём. Есть!
И по той самой инструкции. Всё сработало, только я изначально забыл поставить один пакет и выполнить одну команду. А как только вспомнил и сделал , то всё заработало.
Kubuntu 11.10
+ пакет ethtool
+ команда ethtool -s eth0 wol g; echo enabled > /sys/class/net/eth0/device/power/wakeup"

Последние две строчки для меня загадка, у меня Windows 8 если что, хотя не уверен что это имеет значение.
Откликнитесь, кто может, задача очень насущная и почти необходимая.

Gavrila
Сообщения: 1
Зарегистрирован: 30 сен 2014, 13:12
Страна: Украина

Re: Wake-on-lan на TL-WR1043ND

Сообщение Gavrila » 30 сен 2014, 13:19

KxD писал(а):даа, много воды утекло с начала этой темы, а вопросы все таки остались.
У меня та же история. Комп включается, но только какое-то не большое время после выключения.
А пост от masterlan я так и не понял.
"Вы не поверите ! :)
Я его таки добадал. И несколько раз уже проверил. Есть вейк-ап подъём. Есть!
И по той самой инструкции. Всё сработало, только я изначально забыл поставить один пакет и выполнить одну команду. А как только вспомнил и сделал , то всё заработало.
Kubuntu 11.10
+ пакет ethtool
+ команда ethtool -s eth0 wol g; echo enabled > /sys/class/net/eth0/device/power/wakeup"

Последние две строчки для меня загадка, у меня Windows 8 если что, хотя не уверен что это имеет значение.
Откликнитесь, кто может, задача очень насущная и почти необходимая.
тоже долго возился пока не наткнулся на инструкцию:
Откройте страницу администрирования роутера. Обычно она доступна по адресу 192.168.1.1, но может иметь и другой адрес, в зависимости от настроек вашего роутера.

Сперва зайдите в раздел Forwarding->Virtual Servers и добавьте новую запись для компьютера который вы планируете удаленно включать через интернет. В ней нужно указать его IP адрес и порт, который будет использоватся для включения. Обычно для Wake-On-LAN используется порты 7 и 9, но можно также указать любой другой порт (от 1 до 65535). Для типа протокола задайте значение UDP или ALL.
Изображение
Далее нужно перейти в раздел IP & MAC Binding->Binding Settings и произвести следующие настройки:

Включить опцию Arp Binding.
Добавить новую запись для компьютера который вы будете удаленно включать указав его IP и MAC адреса. Не забудьте также для него включить опцию Bind.
Изображение
помимо этого я еще в настроках DHCP зарезервировал IP под мак-адрес своей сетевой

KxD
Сообщения: 2
Зарегистрирован: 23 май 2014, 22:09
Страна: Украина

Re: Wake-on-lan на TL-WR1043ND

Сообщение KxD » 30 сен 2014, 21:41

Gavrila, спасибо. В описанном выше все верно. Проблема оказалась бональна. Я все так и сделал, но (как это бывает в 90% случаев) все дело в невнимательности. В настройках bind, привязка айпи к маку все настроил, вот только общий тумблер так и остался в дисайбл. (( Как всегда стыдно, но надеюсь кому-нибудь поможет.

Ответить

Вернуться в «TL-WR1043ND / TL-WR1045ND»