FAQ по роутеру - список ответов на часто задаваемые вопросы

Беспроводные гигабитные маршрутизаторы серии N
ga6iem
Сообщения: 13
Зарегистрирован: 11 окт 2011, 10:03

FAQ по роутеру - список ответов на часто задаваемые вопросы

Сообщение ga6iem » 11 ноя 2011, 01:28

Изображение

Краткое описание
Проводные интерфейсы: 1xWAN 1Gbit + 4xLAN 1Gbit
Стандарты Wi-Fi: IEEE 802.11n 300Mbit/s, IEEE 802.11g, IEEE 802.11b
Антенны: 3x3Dbi, съёмные, всенаправленные
Диапазон частот: 2,4-2,4835 GHz
Поддержка USB: 1xUSB 2.0
Поддержка UPnP, DDNS, статичное управление IP, VPN pass-through
Встроенный DHCP сервер с автоматическим присвоением IP
Встроенный Firewall с фильтрацией по MAC, IP, URL
Безопасность: 64/128/152-bit WEP, совместимый с 128 bit WPA стандартом (TKIP/AES), поддержка MIC, IV Expansion,
Мастер настройки маршрутизатора

Аппаратная часть
Чип: Atheros AR9132 400MHz
RAM: 32MB
Встроенная флэш-память: 8MB
Коммутатор: Realtek RTL8366RB
Модуль Wi-Fi: Atheros AR9103

Страничка роутера на официальном сайте
Подробная страничка Wiki (англ.)
Обзор роутера на 3DNews
Обзор роутера на Overclockers.ru

FAQ

1. Общие вопросы

Q: Я выбираю роутер. Расскажите об известных проблемах этой модели.
A:
  1. Некоторые сталкиваются с регулярными зависаниями роутера на "родной" прошивке. Причина неизвестна.
  2. При подключении Dual Access проброс портов работает только во внешнюю сеть, что делает невозможным использование активного режима в DC++, а также доступ к домашним серверам (FTP, HTTP, ...) из локальной сети провайдера.
  3. В начальный момент загрузки роутер "засвечивает" провайдеру MAC-адреса подключенных устройств, что у некоторых провайдеров может привести к бану порта. Происхождение (аппаратное или программное) проблемы неизвестно, но все упоминания о ней относятся к оригинальной прошивке.
Проблемы 1, 2 (и, возможно, 3) решаются установкой сторонней прошивки. Аппаратных проблем (как-то перегрев, массовый выход из строя блока питания или иного узла, и т.д.) у данного роутера не замечено.

Q: С какой скоростью копируются файлы с расшаренного USB-диска/на него?
A: Скорость чтения/записи составляет около 6-7 МБ/с на официальной прошивке (с FAT32) и до 14/10.5 МБ/с на альтернативных (зависит от используемого протокола передачи, ОС и файловой системы).

Q: Какая файловая система быстрее всего работает с роутером?
A: Официальная прошивка поддерживает только FAT32 и NTFS, первая быстрее (но не поддерживает файлы больше 4ГБ). На альтернативных прошивках выбор существенно шире, результаты тестирования можно посмотреть здесь.

Q: Каково энергопотребление роутера?
A: Роутер потребляет 6.9 Вт в режиме простоя и 9 Вт в режиме активной работы (источник).

Q: Убил роутер перепрошивкой. Описанная процедура восстановления не помогает. Как восстановить роутер через Serial?
A: Инструкция.

Q: Как подключить принтер к роутеру? Я не вижу принтера в сетевом окружении Windows
A: Не нужно искать в сетевом окружении. В Windows установите принтер как локальный (не сетевой), во время установки создайте TCP/IP порт с адресом роутера. Обычно 192.168.1.1. Ответ относится к официальной прошивке, где есть принт-сервер, а также Openwrt, dd-wrt.

2. Вопросы по использованию официальной прошивки

Q: Роутер регулярно зависает. Что делать?
A: Существует проблема со стабильностью официальных прошивок последних версий. TP-Link планирует решить проблему, выпустив обновление ориентировочно в феврале-марте. Если ваш роутер подвержен описанной проблеме, для её решения вы можете установить альтернативную прошивку.

Q: После подключения роутера BitTorrent-клиент пишет, что порт закрыт, а DC++ работает в пассивном режиме. Как пробросить порты?
A: Инструкция тут. При соединении типа Dual Access проброс портов в локальную сеть невозможен (см. следующий вопрос).

Q: Мой провайдер использует соединение Dual Access. Я сделал всё по инструкции, но DC++ всё равно работает только в пассивном режиме.
A: На данный момент стоковая прошивка имеет ограничение на проброс портов при подключении по Dual Access: порты пробрасываются лишь во внешнюю сеть, но не локалку. По заверению представителей TP-Link это ограничение будет снято в новых версиях прошивки. Тем не менее, уже сейчас можно пробросить порты в локальную сеть через консоль.

Q: Как при помощи UPnP открывать нужные порты автоматически?
A: Инструкция.

Q: Как расшарить флэшку/диск, подключенный к роутеру?
A: Инструкция.

Q: Провайдер отключил мой порт, ссылаясь на MAC-спуфинг. До покупки роутера всё было нормально.
A: В начальный момент загрузки роутер "засвечивает" провайдеру MAC-адреса подключенных устройств (источник). Если ваш провайдер банит порт в таких случаях, перед включением/перезагрузкой роутера отключайте WAN-кабель и включайте его обратно после полной загрузки роутера.

Q: Как получить доступ к консоли?
A: На официальной прошивке это можно сделать так.

3. Вопросы по альтернативным прошивкам

3.1. Общие


Внимание! Из альтернативных прошивок нельзя прошивать заводские прошивки со словом boot в названии. Их можно прошивать только с заводских. Иначе придется восстанавливать роутер через серийный кабель!
При этом отсутствие слова boot не дает 100% гарантию. Лучше ориентироваться на размер файла прошивки.
boot - 8 258 048 байт, без boot - 8 126 464 байт
В связи у участившимися неудачными прошивками после альтернативных прошивок обращаю внимание на то, что новые заводские прошивки, залитые после альтернативных, приведут роутер в нерабочее состояние. Для восстановления потребуется найти или сделать специальный кабель, разбирать корпус и паять разъём. Поэтому прежде чем что-то делать ознакомьтесь с опытом прошивки в теме. Для возврата на заводскую необходимо пользоваться проверенными версиями.


Q: Зачем нужны альтернативные прошивки? Какие новые возможности они предлагают?
A: Альтернативные прошивки позволяют:
  • устанавливать прямо на роутер BitTorrent-, eDonkey-клиенты, серверы Samba, FTP, NFS, HTTP, IP-телефонии, Proxy, SQL, почтовый, и др., функционирующие без участия компьютера;
  • подключать жёсткие диски с разделами в форматах Ext2, Ext3, Ext4, XFS, ReiserFS, HFS+, BtrFS;
  • увеличить скорость чтения/записи на расшаренный диск в ~2 раза (при использовании быстрых ФС);
  • подключать принтер, делая его сетевым.
Q: Какие альтернативные прошивки можно установить на этот роутер?
A: OpenWrt, DD-WRT, Gargoyle.

Q: Какая прошивка лучше?
A: Ответ здесь.

Q: После обновления официальной прошивки и последующей установки альтернативной перестал работать интерфейс wan.
A: Инструкция по восстановлению.

3.2. Специфичные для DD-WRT вопросы

Q: Как установить DD-WRT?
A: Для прошивки со стока качаем файл factory-to-ddwrt.bin отсюда, в веб интерфейсе скидываем на заводские настройки (System tools - Factory Defaults), далее заходим в System tools - Upgrade и выбираем файл прошивки. После завершения процесса прошивки не забываем сделать сброс 30/30/30. Подробно, со скриншотами тут.

Q: Как перепрошиться обратно на официальную прошивку?
A: Cкачиваем файл web-revert для 1043 отсюда (необходима регистрация на форуме). Делаем сброс 30/30/30. В веб интерфейсе дд-врт Administration - Firmware Upgrade выбираем скаченный файл. После завершения процесса прошивки скачиваем необходимую нам версия заводской прошивки и делаем Upgrade.

Q: Как настроить соединение Dual Access PPTP?
A: Инструкция.

Q: Как настроить/улучшить соединение Wi-Fi?
A: Инструкция здесь.

3.3. Специфичные для OpenWrt вопросы

Q: Как установить OpenWrt?
A: Инструкция.

Q: Для чего файлы прошивок factory и sysupgrade?
A: Файл factory применяется для прошивки Openwrt поверх заводской прошивки. Файл sysupgrade используется для прошивки одной версии Openwrt поверх другой. После прошивки factory не нужно "делать" sysuprade!

Q: Есть ли альтернативные сборки OpenWrt?
A: Здесь можно скачать сборку OpenWrt от Pilot6.
Сборка Pilot6 с минимальным набором пакетов.
Для прошивки pilot6 KaVc сделал репозиторий. Для установки дополнительных пакетов нужно прописать в файле /etc/opkg.conf путь ftp://kavcrl.dyndns.org/+SOFT/+HARDWARE ... 3/packages
Есть еще один репозиторий, куда кладет пакеты Pilot6. ftp://ftp.rtelekom.ru/pub/OpenWRT/Pilot6/

Q: Я "брикнул" роутер. Индикаторы работают, но Web-интерфейс не грузится, по SSH зайти тоже не получается. Что делать?
A: В большинстве случаев достаточно загрузиться в безопасный режим и восстановить OpenWrt. Подробности здесь. Если это не помогает, требуется восстановление через Serial.

Q: Не могу зайти на роутер через SSH. Логин и пароль ввожу правильно, но доступ запрещён.
A: Во избежание несанкционированного доступа после прошивки OpenWrt доступ по SSH закрыт до установки пароля. Нужно зайти, используя телнет, и установить пароль.

Q: Как перепрошиться обратно на официальную прошивку?
A: Просто прошить официальную прошивку через веб-интерфейс Openwrt. Прошивать можно только прошивки без слова boot в названии.

Q: Хочу собрать OpenWrt под себя, но не знаю с чего начать.
A: Инструкция 1, инструкция 2 (англ.).

Q: А можно ли собрать образ попроще, без установки тулчейна и компиляции исходников?
A: Инструкция (англ.).

Q: Как настроить подключение по L2TP с Dual Access
A: Необходимо установить пакет Openl2tp и залить конфигурационные файлы. Из под Windows это удобно сделать при помощи программы WinSCP. Пакет конфигурационных файлов, протестированных для Билайна и инструкция лежит здесь. С большой вероятностью он подойдет для других провайдеров. Готовая прошивка с Openl2tp лежит здесь.

Q: Я получаю не все маршруты по dhcp на Openwrt у провайдера Билайн
A: Это связано с тем, что часть маршрутов Билайн отдает по опции 249, а часть по опции 33. Решение проблемы здесь.

Q: При подключении по Dual Access я не могу попасть на сайт провайдера
A: Срабатывает защита DNS Rebind Protection. Нужно локальные домены добавить в список Domain Whitelist в Network -> DHCP and DNS.
Или выключить Rebind Protection совсем там же (не рекомендуется).

Q: После "клонирования" MAC-адреса роутер или отдельные порты не работает
A: MAC-адрес на порту WAN не должен совпадать с MAC-адресом ни одного устройства в локальной сети. Поэтому при клонировании MAC-адреса нужно поменять адрес у сетевой карты, с которой клонировали. Это происходит потому, что WAN порт реализован при помощи vlan, и свич не допускает наличия одинаковых MAC-адресов даже в разных vlanах. Это замечание вероятно относится и к другим прошивкам, включая заводскую.

Q: Как выделить порт для приставки iptv (bridge lan to wan)?
A: Это можно сделать и из вебинтерфейса. Но проще всего отредактировать файл /etc/config/network.
Для выделения 4-го порта раздел switch должен выглядеть так:

Код: Выделить всё

 config 'switch'
	option 'name' 'rtl8366rb'
	option 'reset' '1'
	option 'enable_vlan' '1'
	option 'enable' '1'
 
config 'switch_vlan'
	option 'device' 'rtl8366rb'
	option 'vlan' '1'
	option 'ports' '1 2 3 5t'
 
config 'switch_vlan'
	option 'device' 'rtl8366rb'
	option 'vlan' '2'
	option 'ports' '0 4 5t'
Q: Как собрать Openwrt с accel-pptp?
A: Инструкция здесь.

Q: Почему в Openwrt работают не все каналы Wi-FI?
A: Это связано с тем, что в EEPROM прошита страна США, а Openwrt не допускает нарушение правил использования Wi-Fi, установленных в стране. Это лечится установкой прошивок от энтузиастов, где разрешен выбор страны или заливкой файла regulatory.bin в /usr/lib/crda отсюда.

Q: Как смотреть IPTV на компьютере.
A: Инструкция для московского Билайна здесь. По аналогии можно настроить на любого провайдера. Поменяются только адреса и маршруты.

Q: Как удобнее всего настраивать Openwrt из-под Windows.
A: Инструкция Zlobnui.

Q: Как настроить самбу и торрент клиент?
A: Инструкция

Q: Как подключить к роутеру камеру для видеонаблюдения?
A: Инструкция здесь.

---
Взято с http://forum.ixbt.com/topic.cgi?id=14:56710
Последний раз редактировалось ga6iem 30 янв 2013, 16:19, всего редактировалось 2 раза.

GDragon
Сообщения: 95
Зарегистрирован: 02 сен 2011, 12:26

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение GDragon » 08 янв 2013, 13:38

Medivh писал(а):Стоит игровой сервер.

Кстати, а есть ли возможность сделать гостевую зону без пароля и с ограничением скорости для каждого?
Дак забаните на самом сервере...
На родной прошивке точно нельзя

lexar
Сообщения: 62
Зарегистрирован: 31 мар 2012, 22:57
Откуда: винные погреба
Контактная информация:

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение lexar » 08 янв 2013, 13:49

Кстати, а есть ли возможность сделать гостевую зону без пароля и с ограничением скорости для каждого?
на офф. прошивке точно нет, придётся пробовать альтернативные, если не страшно...

Вопрос к администрации -
Для моего провайдера требуется поддержка 802.1Q (VLAN). Когда TP-LINK планирует добавить это в прошивку? ибо по этой причине пока TL-WR1043ND отложил в сторону и юзаю противный d-link, в котором 802.1Q (VLAN) почему-то есть в 9 моделях из 10... пора что-то делать... потому что пока 802.1Q (VLAN) в TL-WR1043ND не появится - юзать его не могу...
HW: TL-WR1043ND 1.7
WAN: DynamicIP 100/100 mbps
отсебятина: 2 радиатора: проц+память, сетевой чип
нагрузка: 2 PC с торрентами 12/24 по шнурку
UpTime: с радиаторами и FW 3.11.8/100609 > 2 месяцев
FW: пока нет поддержки VLAN, сижу на D-link DIR-300NRU B7

HellraizeR
Сообщения: 3
Зарегистрирован: 27 фев 2013, 20:22
Страна: Россия

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение HellraizeR » 03 мар 2013, 16:52

Прошу прощения за глупый вопрос, но хочется знать наверняка, на что поменять свой неудачный D-Link.
Данная модель держит PPPOE Dual Access или Dual распространяется только на PPTP/L2TP?
Вопрос актуальный, ибо провайдер предоставляет именно тип подключения PPPOE и без Dual access работает только интернет, а доступа к локальной сети нету, а отсюда невозможность смотреть IPTV

Goodwin
Модератор
Модератор
Сообщения: 3603
Зарегистрирован: 25 май 2011, 10:56
Страна: Россия

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение Goodwin » 05 мар 2013, 13:57

lexar писал(а): Вопрос к администрации -
Для моего провайдера требуется поддержка 802.1Q (VLAN). Когда TP-LINK планирует добавить это в прошивку?
Сейчас поддержка 802.1Q реализована на моделях 741, 740. 841 и 4300 сейчас на стадии тестирования. Следующей на очереди будет 1043. Правда я не уверен, что к этому времени не выйдет новая ревизия этого устройства, и данное добавление не попадёт туда, поэтому ничего гарантировать к сожалению не могу.
Перед тем, как создать тему, посетите раздел ЧАСТО ЗАДАВАЕМЫЕ ВОПРОСЫ
TP-LINK Archer C7v2
Личные сообщения по техническим проблемам без сообщения на форуме не рассматриваются!

Goodwin
Модератор
Модератор
Сообщения: 3603
Зарегистрирован: 25 май 2011, 10:56
Страна: Россия

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение Goodwin » 05 мар 2013, 13:58

HellraizeR писал(а): Данная модель держит PPPOE Dual Access или Dual распространяется только на PPTP/L2TP?
Да, поддерживает и PPPoE u PPTP u L2TP Dual access
Перед тем, как создать тему, посетите раздел ЧАСТО ЗАДАВАЕМЫЕ ВОПРОСЫ
TP-LINK Archer C7v2
Личные сообщения по техническим проблемам без сообщения на форуме не рассматриваются!

LM8047
Сообщения: 2
Зарегистрирован: 14 мар 2013, 19:44
Страна: БЕЛАРУСЬ

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение LM8047 » 14 мар 2013, 20:07

Парни, подскажите,
у меня есть тв LG LM620(smart, DLNA) и стац. комп.+ желание смотреть IPTV(локальная сеть провайдера) на телике без компа и приставки, а также чтоб инет работал и там и там, и на компе ещё и DC++?

Стоит ли покупать TP-LINK 1043ND только из-за этого.
Или же можно взять что-то подешевле для таких манипуляций?
И какими вообще параметрами руководствоваться при выборе.
Извиняюсь если не в тему...

SAT
Сообщения: 26
Зарегистрирован: 13 янв 2012, 20:41

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение SAT » 29 мар 2013, 00:56

1043 не умеет перенаправлять ip-tv на dlna, разве что видел статью по прошивке на альтернативу open-wrt вродь как-то можно
Firmware Version: 3.13.11 Build 121102 Rel.51321n
Hardware Version: WR1043ND v1 00000000
McLaut Cherkasy, Ukraine
PPPoE DualAccess (Internet 25/25 Mbit/s, Lan 100Mbit/s)

Romich
Сообщения: 1
Зарегистрирован: 30 мар 2013, 12:01
Страна: Russia

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение Romich » 30 мар 2013, 12:24

Всем доброго времени суток. Роутер практически всем устраивал до недавнего времени. Был куплен телек на кухню и для связи с инетом приобретен дешевенький роутер тплинк TL-MR3020. Включается кабелем в телек, а беспроводкой подключается к 1043. Проблема в том, что при включении шифрования WPA маленький тплинк не может в течении длительного времени подключится к большому(может 5 мин а может и час). Статус подключения скачет, пишет STA-ASSOC и отваливается. При отключении шифрования - подключается на ура. Маленький роутер пробовал подключать к другому роутеру(asus 500gp) - шифрование не помеха, подключился сразу. Ну и еще один нюанс - если маленький с шифрованием долго не может подключится к 1043, перезагрузка 1043 спасает ситуацию, коннект мгновенный. Прошивки на роутерах последние официальные. Подскажите где может быть собака зарыта, откуда копать? Заранее спасибо.
UPD Прошил ddwrt и все стало как нужно.

djserg-minyar
Сообщения: 3
Зарегистрирован: 09 фев 2012, 06:14

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение djserg-minyar » 16 апр 2013, 08:04

Ребята всем привет, подскажи как на роутере TP Link MR3220 выделить еще один порт под приставку IPTV.
Прошивка стоит OpenWRT.
Конфиг свитча вот такой:
  • root@LAN:~# cat /etc/config/network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

    config interface 'wan'
    option _orig_ifname 'eth1'
    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '10.53.13.79'
    option netmask '255.255.255.0'
    option gateway '10.53.13.1'
    option dns '10.53.4.8 10.53.4.9'
    option ifname 'eth1'

    config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'eth0'
    option vlan '1'
    option vid '1'
    option ports '0 1 2 3 4'
пробовал добавлять еще один влан и выносить в него порты 0 и 4

config switch_vlan
option device 'eth0'
option vlan '1'
option vid '1'
option ports '1 2 3'

config switch_vlan
option device 'eth0'
option vlan '3'
option vid '3'
option ports '0 4'

но теперь получается, что только порт 4 получает IP из локальной сети, а остальные порты вообще не в работе.
А хотелось бы, чтобы в 4м порту приставка получала IP от провайдера через провод в ван порту.

MrT
Сообщения: 14
Зарегистрирован: 01 сен 2011, 19:41

Re: FAQ по роутеру - список ответов на часто задаваемые вопр

Сообщение MrT » 02 май 2013, 23:16

Господа, интересуюсь, существует ли прошивка, в которой (помимо стандартных требований по скорости и стабильности):
1. Работает DynDNS синхронизация.
2. Можно прописать маршрутизацию на мультикаст-группу.

Стоит ли смотреть в сторону DD-WRT с моими запросами?

Ответить

Вернуться в «TL-WR1043ND / TL-WR1045ND»